Fedora iTOps Tube

Wednesday, May 16, 2012

F15 yum update php-*, httpd-* and neither will start...

Neither php or httpd will start after a yum update. I yum updated the following:

php-*, 44M

mysql-*, 44M

httpd-*, 1.9M

glibc, ...

This LAMP server was working fine since I upgraded to F15 last October. I'm having trouble with a PHP framework and thought an update would be useful. :doh:



# php


Code:


PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/mapi.so' - /usr/lib/php/modules/mapi.so:      undefined symbol: _ZN9ECUnknown10IsParentOfEPS_ in Unknown on line 0

libgcc_s.so.1 must be installed for pthread_cancel to work

Aborted


Various solutions called for,

* updating glibc-i686-2.14.1

* add library location of libgcc_s to $LD_LIBRARY_PATH



Apache won't start either.


Code:


# stemctl status httpd.service

httpd.service - LSB: start and stop Apache HTTP Server

  Loaded: loaded (/etc/rc.d/init.d/httpd)

!  Active: active (exited) since Sat, 12 May 2012 13:36:58 -0400; 34min ago

  Process: 1164 ExecStart=/etc/rc.d/init.d/httpd start (code=exited, status=0/SUCCESS)

  Main PID: 1445 (code=killed, signal=ABRT)

  CGroup: name=systemd:/system/httpd.service


Searching through the /var/log/messages, and /var/log/httpd found a few items, one,


Code:


!! May 12 12:05:23 10 systemd[1]: Unit httpd.service entered failed state.

I googled to find the following recommendations:

* add ChrootDir / to httpd.conf

and this also points to the libgcc_s issue which php is experiencing.



any other ideas?




No comments:

Post a Comment